SP 2010 in win 8.1 - Managed Metadata service issue

10-11  Source: Network gathering  Views:2 

Advertisement
I recently installed SP 2010 in my WIN 8.1. Installation was successful and I am able to create and modify sites etc. I am able to deploy solutions via VS2010 as well. all are working fine.
issue 1:
BUT in Central Admin - when I go to Managed Metadata service - I get"The server Method 'Check Permission' failed".
in the ULS log I see
Request for security token failed with exception: System.ServiceModel.ProtocolException: The content type text/html; charset=utf-8 of the response message does not match the content type of
the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
http//www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd>  <html xmlns=http://www.w3.org/1999/xhtml>  <head>  <title>IIS 8.5 Detailed Error - 500.0 - Internal Server Error</title>  <style type="text/css"> 
<!--  body{margin:0;font-size:.7em;font-family:Verdana,Arial,Helvetica,sans-serif;}  code{margin:0;color:#006600;font-size:1.1em;font-weight:bold;}  .config_source code...
Exception occured while connecting to WCF endpoint: System.ServiceModel.ProtocolException: The content type text/html; charset=utf-8 of the response message does not match the content type of
the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd>  <html xmlns=http://www.w3.org/1999/xhtml>  <head>  <title>IIS 8.5 Detailed Error - 500.0 - Internal Server Error</title>  <style type="text/css"> 
<!--  body{margin:0;font-size:.7em;font-family:Verdana,Arial,Helvetica,sans-serif;}  code{margin:0;color:#006600;font-size:1.1em;font-weight:bold;}  .config_source co...
issue 2:
I then clicked "managed meta data service connection" and at that point I get
"The remote server returned an error:
(500) Internal Server Error" with correlation ID - logs below
An exception occurred when trying to issue security token: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+msbin1).
If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd> 
<html xmlns=http://www.w3.org/1999/xhtml>  <head>  <title>IIS 8.5 Detailed Error - 500.0 - Internal Server Error</title>  <style type="text/css">  <!--  body{margin:0;font-size:.7em;font-family:Verdana,Arial,Helvetica,sans-serif;} 
code{margin:0;color:#006600;font-size:1.1em;font-weight:bold;}  .config_source code{font-size:.8em;color:#000000;...
WHAT I DID: I included all file extentions like "aspx", "json", "svc" etc. but no luck.
Hi,
Please browse the below URL
Issue 1
http://blogs.technet.com/b/sykhad-msft/archive/2012/02/25/sharepoint-2010-nailing-the-error-quot-the-security-token-service-is-unavailable-quot.aspx
Issue 2
.Net trust level for Security token service application in IIS may be not set to Full
Thanks and Regards Rahul Dagar
Related articles