[SOLVED] Xorg & Firefox lock Gnome desktop, causing massive CPU usage

10-11  Source: Network gathering  Views:0 

Advertisement
Hi there,
since I have installed ArchLinux x64 on this laptop (Core 2 Duo, 9600M GT with Nvidia's binary driver 195.36.15-2, Gnome 2.30) Xorg spins out of control every so often - more often repeatedly in an hour, sometimes not for a prolonged time.
This appears to occur (so far only) when Firefox is running (with any site, independent of Flash, but looks as if its main window has to be open) with which it then consumes an entire CPU core, making the mouse pointer and any terminal cursor blink rapidly, as well as windows being selectable, but not e. g. resizable or closable. Any keyboard input to a terminal has to be hammered in repeatedly to be accepted.
It also seems as if it is especially prone to happen if another program (say, gThumb) is ordered to switch to full-screen by F11 with FF's window open in the background, which frequently for whatever reason then also wants to change into full-screen, causing "conflict".
Switching to a console and killing Firefox or starting it via terminal and canceling it there ends each occurrence of the issue. Xorg.0.log does not report any errors.
An upgrade to Xorg 1.8 does not appear to have affected it.
I know this bug (or ones like it) has also occurred to others for years now, but I have so far been unable to find any solutions in reports concerning it.
Any help, please?
My xorg.conf (many options in "Device" have been inserted as attempts to solve the issue):
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 ([email protected]) Wed Dec 9 16:34:26 PST 2009
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
Option "ignoreABI" "True"
EndSection
Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/TTF"
FontPath "/usr/share/fonts/Type1"
EndSection
Section "Module"
Load "dri2"
Load "extmod"
Load "dbe"
Load "record"
Load "glx"
EndSection
Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection
Section "InputClass"
Identifier "touchpad catchall"
MatchIsTouchpad "on"
Driver "synaptics"
Option "TapButton1" "1"
EndSection
Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
Option "DPMS" "True"
EndSection
Section "Device"
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "G96 [GeForce 9600M GT]"
Option "AllowIndirectPixmaps" "True"
Option "AllowSHMPixmaps" "0"
Option "AddARGBGLXVisuals" "True"
Option "BackingStore" "True"
Option "DPI" "96 x 96"
Option "DynamicTwinView" "1"
Option "NoLogo" "True"
Option "OnDemandVBlankInterrupts" "True"
Option "PixmapCacheSize" "2000000"
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3333; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x1"
Option "RenderAccel" "True"
Option "TripleBuffer" "True"
EndSection
Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection
edit: I cannot say exactly what apparently ended this issue, however (of the changes I explicitly remember) after the following it does no longer occur:
    1. Had to delete the extensions.* (cache, ini, rdf) files as they became corrupted.
    2. Removed the Fox Splitter (aka Split Browser) extension.
Last edited by misc (2010-06-23 12:14:09)
Daemonjax wrote:Try another browser and see what happens... I like chromium.
Well yes, I though about this too, but that certainly wouldn't solve the problem (esp. were it to appear with other apps); besides, there are just way too many features (extensions, scripts etc.) that Chrome a) does not have or b) would be a royal pain to properly add.
Last edited by misc (2010-04-16 10:01:31)
Related articles
  • [SOLVED] Xorg & Firefox lock Gnome desktop, causing massive CPU usage 10-11

    Hi there, since I have installed ArchLinux x64 on this laptop (Core 2 Duo, 9600M GT with Nvidia's binary driver 195.36.15-2, Gnome 2.30) Xorg spins out of control every so often - more often repeatedly in an hour, sometimes not for a prolonged time.

  • Websites with flash content are causing tremendous CPU usage!! 11-30

    Greetings! I finally installed the long-awaited version 4 of firefox, and I am really disappointed. In addition to slight sluggishness now and again, it turns out that websites with Flash content (even those sites with a little flash advertising bann

  • [10.1.2] Protected Mode causing 100% CPU Usage/Extra Processes on Win XP 32-bit? 11-30

    Hello, I'm not 100% sure if the two are related, but I have a client who was seeing 100% CPU usage using Adobe Acrobat Reader X 10.1.2 on Windows XP 32-bit and Firefox 11. The acrord32.exe process would hang around after closing the main window and e

  • Firefox is eating up between 90% CPU usage to %230 CPU usage, while on a text-only page. I've tried many of the fixits. They didn't work. What can I do? 10-11

    I've cleared cookies multiple times I've emptied the cache I cleared my download history, and a majority of my browsing history I've tried having hardware acceleration for both flash and firefox on and off I turned off all my apps and plugins and whe

  • Spreadsheet functions causing 100% CPU usage 10-11

    Running ColdFusion Enterprise 9,0,0,251028 with JVM 1.6.0_14 on a Windows 2003 server.   I am finding that when using <cfspreadsheet> and the spreadsheet functions to build a spreadsheet the server CPU maxes out at 100% while the spreadsheet object

  • Small Acrobat file causes 100% cpu usage with v. 7.09 11-30

    Using Acrobat professional 7.09 I have a small acrobat file (94k) that causes my cpu to peg at 100% I used acrobat professional to convert an eps file to a pdf file. Is there a general known issue that could be causing this? Stephen> Looking at the p

  • Firefox 3.6.8 causes high cpu on idle (memory fine) 10-11

    For the past week or two (I think maybe since I upgraded to 3.6.8) Firefox has started to take up high amounts of cpu when left to idle, (30% minimum on an E7200 processor, increasing to 50+% when I try and actually use it) which in turn has rendered

  • BizTalk 2013 SFTP Adapter : Host Instance configured for SFTP Receive cause high CPU usage 10-11

    Hi, Our BizTalk 2013 Server test env have 16 GB RAM.  We have one SFTP Receive Location which is using a dedicated Host instance for SFTP receive. As soon as we start this SFTP Host Instance it starts consuming 50-60% CPU. (Even when it is not handli

  • Windows Sharing causing 50% CPU usage 11-30

    I have an iMac Core Duo running 10.4.6, and a few weeks ago the Activity Monitor started showing both CPUs running at about 50% all the time. About 40% of the graph is green (User mode) and 10% is red (System mode) on both CPUs. In addition, there se

  • Use of titles causes excessive CPU usage 10-11

    I have been working on a project in PP CC (all latest updates installed) for the past week.  I have had no problems regardless of the increase in size of the project over time.  Yesterday I began adding a few titles.  After I added the titles the app

  • External Display and AC charger (together ) Causes 70% CPU usage :( 10-11

    Ok, here is what I have : - MacBook Pro 13" early 2011 - Mac OS X Lion 10.7.3 - External Display ( Samsung SyncMaster 2333) - MiniDisplay port to VGA adapter. Here is my problem : When I'm using my computer normally with AC charger plugged in everyth

  • ICal Server and Python causing max CPU usage on 10.5.1 server 10-11

    We are having an issue with iCal Server where a python process is monopolizing the CPU (70%-95%) to the point everything grinds to a halt. Once iCal is stopped, then started again it will be ok for anywhere from 10 minutes to a few hours before it st

  • Configurator panels cause 100% CPU usage bug 10-11

    I'm not sure where to file a bug report, so I am posting this here for now. Has any one else noticed this? (See attached video)I just tried copying and pasting the script from the "Basic Attributes" section of Configurator: ErrStrs = {}; ErrStrs

  • Call Park service causing high CPU usage 11-23

    Hi, I've got a Lync 2013 pool with 4 servers running.  Everything is working fine except I notice that when I enable the call park service, the CPU usage goes from hovering at around 4% to jumping all over the place (anything from 11% to 30%).  I've

  • SQL query against ConfigMgr DB causing 100% cpu usage on SQL server throughout day 11-30

    Hi, I am hoping someone here may have an idea of what I can do to resolve this as I am not much of a SQL guy. Here is what I know. Throughout the day, monday-friday, my ConfigMgr SQL server sits at 98-100% processor usage. Using the following query I

  • Copying from USB NTFS device with Dolphin (KDE) causes 100% CPU usage 11-30

    I am copying +/- 30 GB of Music files (flac) from my external USB HDD which is formatted as NTFS. I have installed ntfs-3g and am experiencing near 100% CPU usage. What's wrong? Additional info: I am using KDE and initiated the copying through dolphi

  • Btrfs + luks cause serious CPU usage 11-30

    I often tried to forget about this, but in a time I use a external disk with btrfs. bus as soon as I mount the disk via luks mapper device, I get serious CPU usage by kthreads. It goes that far that even typing into pidgin gets lagged/delayed. Does a

  • New form fields cause high CPU usage 11-30

    I have a document created by printing an AutoCAD drawing.  As soon as I place a text field (form) in the document, Acrobat freezes for about 2 minutes and Acrobat.exe more than 50% of the CPU.  This happens with each text field placed. To make things

  • Lightroom Mobile Sync - Extremely High CPU Usage/Sync Process Causes LR To Lag 10-11

    Since my other thread doesn't seem to be getting any responses, I'm pasting what I've found here. Please keep in mind I am not a beginner with Lightroom and consider myself very familiar with Lightroom's features excluding the new mobile sync. 1st me

  • Finder has heavy CPU usage: Causing fan to spin constantly 11-30

    Hi, I recently upgraded to Leopard. The upgrade went perfectly. The only thing thats annoying me is that the FINDER is causing heavy CPU usage which is causing my MacBook's fan to spin constantly. I've figured out that the problem is most likely FIND