Problem with syntaxes and structures in unicode

10-11  Source: Network gathering  Views:0 

Advertisement
1. i have a problem with syntax
this is old syntaxes
TRANSLATE c ...FROM CODE PAGE g1 ... TO CODE PAGE g2
new systems should use this class instead of above
CL_ABAP_CONV_IN_CE
it reads data from a container and converts it to the system format.
my old syntax is TRANSLATE header-id FROM CODE PAGE file_tab-codepage.
i need to change to new one by using above class how to do it
2. I have a structure are_buffer and i am working on upgrade of a old report , i have used a sap predefined structure callled arc_buffer from se11, now when i am using offset in one of the perform statement like
PERFORM read_file USING handle_tab_wa-offset record_len
CHANGING arc_buffer(record_len)
error_handling
p_message.
but the system throws a error called ''the structure arc_buffer(record_length) does not start with character-type field''.
i cannot change the structure becoz its sap standard structure .
how to get out of this.
Moderator message - Cross post locked
Rob
Related articles
  • Problem with syntaxes and structures in unicode 10-11

    1. i have a problem with syntax this is old syntaxes TRANSLATE c ...FROM CODE PAGE g1 ... TO CODE PAGE g2 new systems should use this class instead of above CL_ABAP_CONV_IN_CE it reads data from a container and converts it to the system format. my ol

  • Problem with writing and reading using serialization 10-11

    I am having a problem with writing and reading an object that has another object in it. The purpose of the class is to write a order that has multiple items in it. And there will be several orders. This is for an IB project, where one of the requirem

  • Tp ended with error code 0247 - addtobuffer has problems with data- and/or 10-11

    Hello Experts, If you give some idea, it will be greatly appreciated. This transported issue started coming after power outage, sap system went hard shutdown. Then we brought up the system. Before that , we do not have this transport issue. our TMS l

  • G4 mini has a problem with its volume structure 10-11

    My G4 mini has a problem with its volume structure according to Tech Tools Deluxe. One that the application can't seem to repair. Ran it 3 times and it always hangs before it completes the fix. Never hangs in exactly the same place in the repair rout

  • Problem with JFrame and busy/wait Cursor 10-11

    Hi -- I'm trying to set a JFrame's cursor to be the busy cursor, for the duration of some operation (usually just a few seconds). I can get it to work in some situations, but not others. Timing does seem to be an issue. There are thousands of posts o

  • Problem with installing and running some applications or drivers 10-11

    When installing and installing some items, towards the end of the installation I get this message: /System/Library/Extensions/comcy_driver_USBDevice.kext *was installed improperly and cannot be used. Please try reinstalling it or contact product's ve

  • Problems with outlook and address book contacts: my outlook contacts had around 3,000 entries. Outlook duplicated by itself and now outlook and address book have each over 340,000. What should I do? 10-11

    Problems with outlook and address book contacts: my outlook contacts had around 3,000 entries. Outlook duplicated entries and have now 340,000. I reinstalled microsoft office and, thus, outlook, and reinstalled mac OS X system and applications. While

  • Problems with Safari and Firefox (HTTP?) 10-11

    Problems with Safari and Firefox (HTTP?) On a laptop G4, 10.5.8 and Safari 5.02 I experience the following: On the account of my oldest daughter everything works fine, i.e. wireless internet works and no problems with mail or safari. On the same lapt

  • Haven't been able to use pages for a while.  Keep getting following message.  Have tried reinstalling iWork, but no luck.  Same problems with Keynote and Numbers/Users/scottmcdonald/Desktop/Screen Shot 2012-03-14 at 9.39.52 PM.png 10-11

    Haven't been able to use pages for a while.  Keep getting following message.  Have tried reinstalling iWork, but no luck.  Same problems with Keynote and Numbers/Have you moved Pages from its installed location? Or just dragged a copy to your current

  • Problem with DMGs and error: "No Mountable File Systems" 10-11

    Problem with DMGs and error: "No Mountable File Systems" The files are not corrupt. The problem is occurring with all DMGs that are apparently formatted in MS-DOS FAT16. No the file will not mount with Disk utility or any other disk mounter prog

  • Problem with Send and Receive Emal In SAP System 10-11

    Hi gurus! I have a following quote: Dear ! I have a problem with send and receive email in SAP system following : I want to test send and receive email in local network at my company. I had two server Server 1 : I setup Exchange Mail Server 2007 with

  • Problem with Speaker and Headset in Windows Vista 10-11

    Hi, I just got my Macbook Pro 13" and having problem with speaker and headset when working with Windows Vista (I have installed the driver from bootcamp). The sound very weak if I play music from Itunes or youtube even the volume already full and if

  • Problem with trigger and entity in JHeadsart, JBO-25019 10-11

    Hi to all, I am using JDeveloper 10.1.2 and developing an application using ADF Business Components and JheadStart 10.1.2.27 I have a problem with trigger and entity in JHeadsart I have 3 entity and 3 views DsitTelephoneView based on DsitTelephone en

  • Problem with ADS and LDAP 10-11

    Problem with ADS and LDAP I have installed Win2000 + sp1 and ADS on a computer. This computer is PDC. After connection via LDAP I cann't get any object ( users or goups etc. ). I try connect to ADS by java ( JNDI ). When I use another clients of LDAP

  • Problem with Rescue and Recovery after installing Norton Internet Security 2010 10-11

    Hi all. It's my first time in this forum. I have a problem, with Rescue and Recovery, after installing Norton Internet Security 2010 on my T43. The message I get it: "Rescue and Recovery is unable to back up the file 'C:\Documents and settings\all Us

  • Problem with dreamweaver and Flash 10-11

    Hi, maybe someone can help me, i have any problem with dreamweaver and flash, i have a page and i have a menu and sub-menu, and the same page i have a category en flash 550 x 700 ( photography and more... ) but when the menu to unfold the menu to see

  • Problem with Preview and PSD files - random gray square 10-11

    Hi guys, hope you can help... I've got a problem with Preview and PSD files. If I open in Preview both an original jpg straight from my reflex and the photoshop version of the same picture, the psd file presents a gray square (of what it seems unrend

  • Problem with ECS and XSD 10-11

    Hi B2B Gurus, We are facing the problem with ECS and XSD files from past 2 weeks, Steps we followed 1. Created a ECS file in document editor version 11g: 6.6.0 2. ECS files consists only from ST and SE segments Ex: ST BCH CUR REF PER -- Exclude TAX -

  • Problem with modules and ModuleLoader 10-11

    Hi everybody, i'm facing a real funny problem with modules and moduleLoader, i hope it's not (only) my fault anyway... If i create a normal flex project with fBuilder, i'm able to use modules in a lot of different ways (as mxml, as as in a function e

  • Problem with axis2 and Tomcat 10-11

    Hello, I am having a strange problem with Tomcat and axis. I have a webservice that uses axis2 for wsdl2java class generation. When I compile my project in maven a Test is performed. During the test a glassfish server is established and the project i