NullPointerException problem when  deploying hello1 example.

10-11  Source: Network gathering  Views:0 

Advertisement
I am running Sun AppServer Edition 8.0 on Windows 2000 platform. When I
executed asant build command, Build Successful message was displayed.
To configure the Web application, I followed the steps outlined on how
to package the application using the deploytool in Chapter 3 of the
tutorial. Again I used the steps outlined on how to deploy the
packaged web module using the deploytool to deploy the application
on the Sun AppServer. However the deployment failed with
NullPointerException message.
Here is a listing of the error message:
DetailsTimestamp:Nov 30, 2004 08:13:41.174
Log Level: WARNING
Logger:javax.enterprise.system.tools.admin
Name-Value Pairs:_ThreadID=11;
Record Number:106
Message ID:ADM1026
Complete Message
Redeployment failed - Detailed Message:java.lang.NullPointerException     at
com.sun.enterprise.admin.mbeans.ApplicationsConfigMBean.getHostName(ApplicationsConfigMBean.java:3045)     at
com.sun.enterprise.admin.mbeans.ApplicationsConfigMBean.setHostAndPort(ApplicationsConfigMBean.java:3038)     at
com.sun.enterprise.admin.mbeans.ApplicationsConfigMBean.deploy(ApplicationsConfigMBean.java:274)     at
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)     at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)     at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)     at
java.lang.reflect.Method.invoke(Method.java:324)     at
com.sun.enterprise.admin.MBeanHelper.invokeOperationInBean(MBeanHelper.java:287)     at
com.sun.enterprise.admin.config.BaseConfigMBean.invoke(BaseConfigMBean.java:280)     at
com.sun.jmx.mbeanserver.DynamicMetaDataImpl.invoke(DynamicMetaDataImpl.java:221)     at
com.sun.jmx.mbeanserver.MetaDataImpl.invoke(MetaDataImpl.java:228)     at
com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:823)     at
com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:792)     at
sun.reflect.GeneratedMethodAccessor56.invoke(Unknown Source)     at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)     at
java.lang.reflect.Method.invoke(Method.java:324)     at
com.sun.enterprise.admin.util.proxy.ProxyClass.invoke(ProxyClass.java:54)     at $Proxy1.invoke(Unknown Source)     at
com.sun.enterprise.admin.server.core.jmx.SunoneInterceptor.invoke(SunoneInterceptor.java:282)     at
com.sun.enterprise.admin.jmx.remote.server.callers.InvokeCaller.call(InvokeCaller.java:38)     at
com.sun.enterprise.admin.jmx.remote.server.MBeanServerRequestHandler.handle(MBeanServerRequestHandler.java:92)     at
com.sun.enterprise.admin.jmx.remote.server.servlet.RemoteJmxConnectorServlet.processRequest(RemoteJmxConnectorServlet.java:
69)     at
com.sun.enterprise.admin.jmx.remote.server.servlet.RemoteJmxConnectorServlet.doPost(RemoteJmxConnectorServlet.java:94)     at
javax.servlet.http.HttpServlet.service(HttpServlet.java:768)     at
javax.servlet.http.HttpServlet.service(HttpServlet.java:861)     at sun.reflect.GeneratedMethodAccessor60.invoke(Unknown
Source)     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)     at
java.lang.reflect.Method.invoke(Method.java:324)     at
org.apache.catalina.security.SecurityUtil$1.run(SecurityUtil.java:289)     at
java.security.AccessController.doPrivileged(Native Method)     at
javax.security.auth.Subject.doAsPrivileged(Subject.java:500)     at
org.apache.catalina.security.SecurityUtil.execute(SecurityUtil.java:311)     at
org.apache.catalina.security.SecurityUtil.doAsPrivilege(SecurityUtil.java:205)     at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:283)     at
org.apache.catalina.core.ApplicationFilterChain.access$000(ApplicationFilterChain.java:102)     at
org.apache.catalina.core.ApplicationFilterChain$1.run(ApplicationFilterChain.java:192)     at
java.security.AccessController.doPrivileged(Native Method)     at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)     at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:263)     at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:156)     at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:569)     at
org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:261)     at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:215)     at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:156)     at
org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:583)     at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:154)     at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:569)     at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:200)     at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:156)     at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:180)     at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:154)     at
org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:582)     at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:154)     at
com.sun.enterprise.webservice.EjbWebServiceValve.invoke(EjbWebServiceValve.java:134)     at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:154)     at
com.sun.enterprise.security.web.SingleSignOn.invoke(SingleSignOn.java:254)     at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:154)     at
com.sun.enterprise.web.VirtualServerValve.invoke(VirtualServerValve.java:209)     at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:154)     at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:569)     at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:161)     at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:156)     at
com.sun.enterprise.web.VirtualServerMappingValve.invoke(VirtualServerMappingValve.java:166)     at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:154)     at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:569)     at
org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:979)     at
org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:211)     at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:692)     at
org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:647)     at
org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:589)     at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:691)     at
java.lang.Thread.run(Thread.java:534)
Here is the output from asant listprops command.
Buildfile: build.xml
listprops:
[echo] Path information
[echo] j2ee.home = C:/Sun/AppServer
[echo] env.Path = .;
c:\oracle\ora92\bin;
c:\oracle\ora92\sqlj\bin;
C:\Program Files\Oracle\jre\1.3.1\bin;
C:\Program Files\Oracle\jre\1.1.8\bin;
C:\Ant\apache-ant-1.6.2\bin;
C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;C:\Program Files\Microsoft SQL
Server\80\Tools\Binn\;
c:\mysql\bin;
c:\j2sdk1.4.2_06\bin;
c:\Sun\AppServer\bin;
c:\Sun\AppServer\bin;c:\Sun\AppServer\jdk\bin;
C:\Documents and Settings\sam darko\jwsdp-1.1\jwsdp-shared\bin;
C:\Program Files\Microsoft Visual Studio\Common\Tools\WinNT;
C:\Program Files\Microsoft Visual Studio\Common\MSDev98\Bin;C:\Program Files\Microsoft Visual
Studio\Common\Tools;
C:\Program Files\Microsoft Visual Studio\VC98\bin;
C:\Program Files\MSXML 4.0;
C:\Ant\apache-ant-1.6.2\bin;
c:\mysql\bin;
c:\bea\weblogic81\server\bin;
C:\;
C:\ERCDTMP;C:\ERCDTMP\BIN;C:\ERCDTMP\TOOLS\PT1
[echo] env.PATH = ${env.PATH}
[echo] Classpath information
[echo] classpath = .;
c:\Sun\AppServer\lib\j2ee.jar;
c:\Sun\AppServer\jdk\lib\tools.jar;
C:\Program Files\Altova\xmlspy\XMLSpyInterface.jar;
c:\bea\weblogic81\server\lib\weblogic_sp.jar;
c:\bea\weblogic81\server\lib\weblogic.jar;
C:\jakarta-struts-1.1\lib\struts.jar;
c:\JSTL1.1\jstl-1.1.2\lib\jstl.jar;
c:\JSTL1.1\jstl-1.1.2\lib\standard.jar
[echo] Admin information
[echo] admin.password = ${admin.password}
[echo] admin.host = localhost
[echo] admin.user = admin
[echo] admin.port = 4848
[echo] https.port = 8090
[echo] Domain information
[echo] domain.resources = "domain.resources"
[echo] domain.resources.port = 8091
[echo] Database information
[echo] db.root = C:/Sun/AppServer/pointbase
[echo] db.driver = com.pointbase.jdbc.jdbcUniversalDriver
[echo] db.host = localhost
[echo] db.port = 9092
[echo] db.sid = sun-appserv-samples
[echo] db.url = jdbc:pointbase:server://localhost:9092/sun-appserv-samples
[echo] db.user = pbpublic
[echo] db.pwd = pbpublic
[echo] url.prop = DatabaseName
[echo] ds.class = com.pointbase.jdbc.jdbcDataSource
[echo] db.jvmargs = -ms16m -mx32m
BUILD SUCCESSFUL
Total time: 5 seconds
I just ran the hello1 example on a Win2K system from the command line without seeing the problems that you encountered. I am running a later version of the Application Server than you are (8.1 PE vs. 8.0) and am using the tutorial sources that were designed to be used with that version of the tutorial:
- Use Update 3 version of the tutorial with Application Server 8.1
- Use Update 2 version of the tutorial with Application Server 8.0 Update 1
I haven't tried it with deploytool yet, but built, packaged, and deployed using the asant instructions, as follows.
1. Start the Application Server.
2. In a terminal window, change to the j2eetutorial14/examples/web/hello1 directory.
3. Build the example: asant build
4. Package the example: asant create-war
5. Deploy the example: asant deploy-war
6. In your browser, go to http://localhost:8080/hello1and enter your name.
If you do this do you see the same problem? If you do, where do you encounter that problem? On deployment?
In the meantime, I'll try to package and deploy with deploytool and report back with my results.
Hope this helps.
~Eric
Related articles
  • NullPointerException problem when  deploying hello1 example. 10-11

    I am running Sun AppServer Edition 8.0 on Windows 2000 platform. When I executed asant build command, Build Successful message was displayed. To configure the Web application, I followed the steps outlined on how to package the application using the

  • Sessions problem when deploying to AS 10g (10.1.2.0.2) 11-30

    Hello, I have a very simple Web Application where I have isolated an issue I have found. The application works fine when executed in JDeveloper 10g (10.1.2.2) but it does not work when deployed in the AS 10g (10.1.2.0.2). My Platform is Windows XP Pr

  • Problems when deploying web service onto Weblogic 12c 11-30

    Hello everybody: Created a web service with MyEclipse 8.5; when deploying onto Weblogic I'm facing this next problem: Nov 3, 2012 7:44:40 AM com.sun.xml.ws.transport.http.servlet.WSServletDelegate destroy INFO: WSSERVLET15: JAX-WS servlet destroyed N

  • Exception when deploying CD example 11-30

    Hi I am trying to deploy CD example. Using db2 as backend. I am following exactly as the tutorial said but when i copy cd.jar into deploy directory i get this error ========================================================= org.jboss.deployment.Deploy

  • Asant problem- building the hello1 example 11-30

    I am trying to run the first example from the tutorial.I followed the instructions as described in the tutorial and configured the environment variables. However, when I am trying to build the hello1 example I get the following message: Usage: java [

  • Problems when deploying a WD-Project of NWDS to CE by using ESWorkpl. 10-11

    Hello, I am using a CE 7.1 Server. Now I wanted to develop a Demo App. as described in the Book "Java Programming with SAP NetWeaver", published by SAP Press. I have done everything exactly as described in the book, but If i deploy and run the A

  • Problem when deploying CRXIr2 + VS2005 10-11

    Post Author: Aksu CA Forum: Deployment I have a problem with report loading when I have deployed windows project. Everything is working fine in "development environment". I deploy the project with MS-installer and CRXIr2 merge module (CrystalRep

  • Classpath problem when deploying a persistence unit (in JBoss) 11-30

    Hello, I have a JAR file containing an EJB with a persistence.xml file. I also have another JAR project containing a persistent annotated POJO class that the persistence unit is supposed to map. I defined the class in the persistence unit using a cla

  • URGENT: Substitution Problem when deployed in Server 11-30

    Hello: I am facing a strange problem in student system self-service application customization in oxford university. I have create a new XxigsPersProgAttemptVO extending PersProgAttemptVO and done the substitution. When run the the page though JDev it

  • Problem when deploying Crystal Report application on weblogic 10.3 10-11

    I created a Crystal Report application, using Eclipse , but when i tried to run the correspondant EAR on Weblogic 10.3 i encountered this exception , i guess it is a missing JAR but i didn't know which one : Error 500--Internal Server Error com.cryst

  • [ERROR CODE DPL.DS.5107] problem when deploying an app (Bad version number) 11-30

    Dear colleagues, please find attached a Java exception trace, where I tried to deploy a sample application to my CE 7.1 (only Java version). I use JDK version 1.6.0_06: do you know this problem? Do you have any hints? Compatibility level is put to "6

  • Problem when deploy portlet to oracleAS 10.1.2 11-30

    i was develpe my portlet using jdevlper and jsr 168 and when i was try to deploy it to oracleAS 10.1.2 i get error like this Failed to deploy web application "testPortlet". Failed to deploy web application "testPortlet". . Nested excep

  • Problems when deploying EJB 11-30

    Hi, I try to deploy an ejb in oracle 8.1.7. All the steps of the deployment work fine until the step : "Generating EJBHome and EJBObject on the server..." At this step, it returns the following error messages : Compilation errors in oracle/auror

  • Problem when deploy adobe interactive form 10-11

    Hai all, i am new to adobe interactive form designing, i had developed a simple adobe form, the following error occured while running the application, i had followed the procedure to "Installing a credential for Adobe Document Services" Help me

  • ORA-01017 when deploying cube 11-30

    Hi all, I'm experiencing problems when deploying the SALES cube in the SALES_WH shemas of the demo example. The source is XSALES schemas, where I have imported data from xsales.dmp file. When deploying dimensions no problem occurs. But when deploying

  • Error when deploying a simple Entity bean (EJB3) on Glassfich or Sun AS 10-11

    Hi, After some problems when deploying complex EJB3 Entity bean on GlassFich with a MySQL connector, I have made a simple entity. (test with Glassfish and Sun AS with same result) With netbean 5.5 => New EJB Module File->New->Persistence Unit (an

  • "Error Dialog: The server could not be contacted " when deploying web srvc 10-11

    I have the J2EE 1.4 and Application Server 8 Q1 installed under windows. I have used all of the defaults on the install. The admin port is 4848. I want to install a web service on the http listener at 3345 (8080 was used and 3345 was substituted at i

  • Error occurs when deploy my App to iPhone OS2 11-30

    Hi, I am a newbee in iPhone development. I have met a problem when deploy my simple application to iPhone OS2.0 I create my app via XCode, by using the framework in iPhone SDK.(The SDK is the latest version, I downloaded several days ago) After I suc

  • Problem with fonts in forms when deployed on web 10-11

    Hi everybody out there! Please help me out. My problem is: I have used developer server to deploy forms on web, but when a form is shown on web, it takes some default settings for fonts and colors instead of retaining the original colors and fonts th

  • Java.lang.NullPointerException when deploying 10-11

    My developers are running into an issue when deploying onto our BPM cluster. At times deployment fails giving these errors. Redeploy the same code immediately it works. It seems like it's only failing on the second managed server though... ####<Aug 1