NoClassDefFoundError at runtime

10-11  Source: Network gathering  Views:0 

Advertisement
Hi, everybody:
I am a new commer to Java programming. I recently downloaded and installed the Java JDK 1.3.1 version on my Windows 98 and Windows 2000 computers without any installation problem. I wrote a very simple program and compiled from command prompt without any error. But when I ran the compiled program from command prompt, I got the following error in both Windows 98 and Windows 2000 computers:
Exception in thread "main" java.lang.NoClassDefFoundError: HelloWorldApp
Before I compiled and ran the program, I had checked the PATH and CLASSPATH system variables in the startup AUTOECEC.BAT just to make sure the system enviroment setting is correct. The program I wrote was simple enough just to include a class and main declaration that will display "Hello" on the command prompt.
Can somebody offer any solution for this? please respond your helpful advice to
[email protected]
6-10-2002
Thanks.
hi,
make sure that classpath is set to your current working directory like the following :
set CLASSPATH=.;%CLASSPATH%
note : there is a dot after = sign and before (semicolon)
Related articles
  • Java.lang.NoClassDefFoundError in Runtime Workbench 11-30

    Hello, I am getting  java.lang.NoClassDefFoundError: com/sap/aii/rwb/rtcheck/rtcserver/Processor error while trying to run Component Monitoring in runtime workbench. Please advise!! Thanks a lot Edited by: Chanakya Sharma on Jun 13, 2010 9:47 AMDear

  • NoClassDefFoundError at runtime 10-11

    Hi, everybody: I am a new commer to Java programming. I recently downloaded and installed the Java JDK 1.3.1 version on my Windows 98 and Windows 2000 computers without any installation problem. I wrote a very simple program and compiled from command

  • Bug:WEB-INF/lib JARs not added to runtime classpath of WebLogic Server 11-30

    The JAR files packaged in the WEB-INF/lib directory of an application do not get installed to the runtime classpath of the Weblogic server. Edited by: dvohra16 on Feb 28, 2013 9:24 AMSome posts in which an external jar, usually a JDBC jar, had to be

  • Problem starting weblogic server 10-11

    Can I use third party libraries with the evaluation copy of the weblogic server? I am having problems starting the weblogic server with third party libraries (i.e. oralce's sqlj's translator.zip, runtime.zip and classes2.zip). The following exception

  • JAR files for SQLJ and JDBC drivers: what is the best practice? 10-11

    starting a migration from IAS 10 to WebLogic 11g. Apparently the jar files for SQLJ are not on the classpath by default. java.lang.NoClassDefFoundError: sqlj/runtime/ref/DefaultContextwhich is the better practice: putting the SQLJ runtime jar into th

  • Error while calling SQLJ procedure 10-11

    Hi all, I am using a datasource created in WebSphere to call the SQLJ procedure from an EJB. I am getting the following error trace while instanting the SQLJ procedure class. I am using Spring's DAO Service-config to get the Datasource and thus the C

  • Verify a jar's manifest class-path 11-30

    I want to verify a jar file's manifest class-path. By that I mean I want to verify that every import of every class in the jar file is reachable on the classpath specified in the jar file's manifest. I tried using a ClassLoader to load every class in

  • Installing Doug Lea's concurrent Package (easy) 11-30

    Hi, I'm having trouble getting Doug's package to work, probably because I didn't install correctly. I unzipped into the folder "C:\Java", which created "C:\Java\concurrent", containing all the files. I added this latter folder to my cl

  • Problem in intermedia Please help me! 11-30

    I am University student in South Korea. I'm major in Computer Engineering. I'm using Oracle 9i. And then I'm using 'intermedia' package. I'm interesting in Content-based retrieval. Among them, I'm interesting in Image retrieval. But problem is happen

  • Get NoClassDefFoundError: javax/faces/context/FacesContext Error at Runtime 10-11

    I'm in 11g, PS1. I have an application and I have a SelectOneChoice component that invokes a managed bean (i.e. #{queryHandler.availableFilterChoice}). It then calls my constructor public QueueHandler and within that constructor i have the following

  • DMSConsole Runtime Exception stack trace: java.lang.NoClassDefFoundError 11-30

    I think this is the right place to post the problem. I've already posted my problem here -> https://forums.oracle.com/forums/thread.jspa?threadID=2386699&tstart=0 Can you please let me know where am I missing? Thanks. It is removed from this link.

  • Java.lang.NoClassDefFoundError: com/bea/wlw/runtime/core/bean/SLSBContainer 11-30

    Get the following error during application deployment in a ALDSP only Domain. Note this error happens only when the application contains a jws file exposing a Dataservice as a web-service: java.lang.NoClassDefFoundError: com/bea/wlw/runtime/core/bean

  • Runtime error : java.lang.NoClassDefFoundError 11-30

    hi , i am using IWorkspaceRoot,IResource classes in my application. for which i have included the necessary jar files. but at the runtime i am getting the following exception. com.sap.tc.webdynpro.services.exceptions.WDRuntimeException: Failed to cre

  • Runtime error java.lang.NoClassDefFoundError- FacetDescriptor 11-30

    Hi everybody, I am trying to use a progressbar component in a page that worked fine just before I dropped this component. Now, I am getting the following exception: Exception Details: java.lang.NoClassDefFoundError com/sun/rave/designtime/faces/Facet

  • Runtime classpath issue -- NoClassDefFoundError 10-11

    Hi, It shames me to post such a common, everyday problem, but I cannot figure this one out. I have a class in the package service: service.SynchImage. I have a class in another package as well: vigra.matlab.LOTFClient. In LOTFClient, I am importing s

  • Runtime exception: NoClassDefFoundError: com/sapportals/htmlb/Component 10-11

    Hi, I'm trying to use htmlb to have some javascript in my page: Button myButton = (Button) view.getElement("DNMO.MainWindowView.testButton"); myButton.setJsObjectNeeded(true); but at run time this exception is raised:   java.lang.NoClassDefFound

  • Runtime Error in Portal Application 10-11

    Can any body help me in resolving the following runtime error in portal application, (Netweaver Version : 7.0) Full Message Text 03:21_21/09/11_0002_6275851 [EXCEPTION] java.lang.NoClassDefFoundError: org.apache.commons.httpclient.methods.RequestEnti

  • Error during generation of the WSDL:  BUILD FAILED java.lang.NoClassDefFoundError: com/sun/javadoc/Type 10-11

    When I create an EJB Transport Business Service, after selecting the jar that has the EJB 2.1 artefacts (Remote, Home, etc) the oepe plugin fails and can't continue. As I understand it seems that there is a problem with the classpath of ant build.xml

  • Java.lang.NoClassDefFoundError: com/sapportals/wcm/util/pcr/PortalComponent 10-11

    Hi All, I am getting the following Portal Runtime error while accessing the KM Content on Content Administration. In the error log following class is involved com.sapportals.wcm.portal.component.base.ControllerComponent The error caused by: Caused by

  • Java.lang.NoClassDefFoundError: com/sap/util/monitor/jarm/TaskMonitor 10-11

    hi all, i was trying to build and try a web service in my project. but at runtime it keeps throwing the following error(  log trace) i am unable to figure out the source of error. is it in the jco or anything else thanks in advance 1.5#001143C809E500