IPhone 4 bluetooth no longer working in my 2010 Hyundai Tucson. Need Help.

10-11  Source: Network gathering  Views:2 

Advertisement
Hi.  I have a 2010 Hyundai Tucson.  In June of this year I bought the iphone 4.  I was able to use the bluetooth / pairing in my Tucson with no problems.  It was great because I could just push the buttons on my steering wheel to talk on my phone through the car!  It worked until two or three weeks ago.  Now my Tucson will not "pair" with the phone.  My phone identifies that it is "Tucson" it is trying to link up with but won't ever do it.  Sometimes the keyboard comes up on my phone so I can type in a 4 digit password (0000) provided by my Tucson, but it disappears before I can get the password typed in and gives me a message saying I took too long, pairing failed.  I am typing REALLY fast but it is not fast enough.  I have read a few other posts and looks like their might be a problem with the latest update for the iphone 4.  What am I supposed to do now?  Is their a place I report this to Apple at?  Any suggestions appreciated.  Thanks!
I am having the absolute exact same problem with my 2010 Hyundai Tucson.  After reading some of the other forum posts, it appears that this may be related to an iPhone update.  Have you had any luck with a solution?  I'm so frustrated.  To make matters worse, I was trying to trouble shoot the problem and narrow the issue, so I took my husband's Nokia Lumina phone to see if I could pair it....paired it within seconds.  No problem!  Ughhhhhh!  I need some suggestions.
Related articles