Error While Deploying the BPEL Process using obant script

10-11  Source: Network gathering  Views:0 

Advertisement
Hi All,
I am getting the following error while deploying the BPEL Process using obant script. we are using the BPEL Version 10.1.2.0.2.Any information in this regard will be really helpful.
Buildfile: build.xml
main:
[bpelc] file:/home5102/dibyap/saravana/Test/CreditRatingService.wsdl
[bpelc] validating "/home5102/dibyap/saravana/Test/CreditRatingService.bpel" ...
BUILD FAILED
/home5102/dibyap/saravana/Test/build.xml:15: ORABPEL-01002
Domain directory not found.
The process cannot be deployed to domain "default" because the domain directory "/opt02/app/ESIT/oracle/esit10gR2iAS/BPEL10gR2/iAS/integration/orabpel/domains/default/deploy" cannot be found or cannot b
e written to.
Please check your -deploy option value; "default" must refer to a domain that has been installed locally on your machine.
Total time: 23 seconds
[email protected]_ESIBT:/home5102/dibyap/saravana/Test>
Thanks,
Saravana
In 10.1.2.0.2 you need to create your own build.xml
I have found an example, it may be of some help. This does call a property file
cheers
James
<?xml version="1.0" ?>
<!-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Run cxant on this file to build, package and deploy the
ASB_EFT BPEL process
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -->
<project name="ASB_EFT" default="main" basedir=".">
<!-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Name of the domain the generated BPEL suitcase will be deployed to
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -->
<property name="deploy" value="default" />
<!-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
What version number should be used to tag the generated BPEL archive?
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -->
<property name="rev" value="1.0" />
<!-- BPEL Best Practices Properties -->
<!-- Defaults Properties for TARGET environments
# CHANGE THIS FILE TO REFLECT THE TARGET ENVIRONEMNT
# either dev, test, or prod.properties
-->
<property file="ebusd.properties"/>
<property name="env" value="${env.name}"/>
<property name="current.project.name" value="${project.name}"/>
<property name="target.project.name" value="${project.name}_${env}"/>
<property name="deployment.profile" value ="${env}.properties"/>
<property name="source.development.directory" location="${basedir}"/>
<property name="target.env.directory" location="${basedir}/deploy/${project.name}_${env}"/>
<property file="${deployment.profile}"/>
<property name="build.fileencoding" value="UTF-8"/>
<!-- Prints Environment
-->
<target name="print.env" description="Display environment settings">
<echo message="Base Directory: ${basedir}"/>
<echo message="Deployment Profile: ${deployment.profile}"/>
<echo message="target.env.directory: ${target.env.directory}"/>
<echo message="Deploy to Domain: ${deployToDomain}"/>
<echo/>
<echo message="os.name: ${os.name}"/>
<echo message="os.version: ${os.version}"/>
<echo message="os.arch: ${os.arch}"/>
<echo/>
<echo message="java.home: ${java.home}"/>
<echo message="java.vm.name: ${java.vm.name}"/>
<echo message="java.vm.vendor: ${java.vm.vendor}"/>
<echo message="java.vm.version: ${java.vm.version}"/>
<echo message="java.class.path: ${java.class.path}"/>
<echo/>
<echo message="env: ${env}"/>
<echo message="current.project.name: ${current.project.name}"/>
<echo message="target.project.name: ${target.project.name}"/>
<echo message="server.name: ${server.name}"/>
</target>
<!--
Copies the current directory structure along with
all the file into the target.env.directory and
change the name of the project
-->
<target name="create.environment">
<copy todir="${target.env.directory}">
<fileset dir="${basedir}"/>
<filterset begintoken="@" endtoken="@">
<filtersfile file="${deployment.profile}"/>
</filterset>
</copy>
<move file="${target.env.directory}/${current.project.name}.jpr" tofile="${target.env.directory}/${target.project.name}.jpr"/>
</target>
<target name="main">
<!-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
the bpelc task compiles and package BPEL processes into versioned BPEL
archives (bpel_...jar). See the "Programming BPEL" guide for more
information on the options of this task.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -->
<bpelc input="${basedir}/bpel.xml" rev="${rev}" deploy="${deploy}" />
</target>
</project>
here is a property file
project.name=ASB_EFT
env.name=ebusd
deployToDomain=default
server.name=[server]
server.port=7788
ebusd\:7788=http://[server]:7788/
IntegrationMailAccount=OracleBPELTest
IntegrationMailAddress=[email]
IntegrationMailPassword=[password]
archivedir=[directory]
inbounddir=/[directory]
errordir=[directory]
outbounddir=[directory]
bpelpw=bpel
dbhost1=[dbserver]
dbhost2=[dbserver]
dbport=1523
dbservice=bpel
dbconnstr=jdbc:oracle:thin:@(DESCRIPTION=(LOAD_BALANCE=YES)(FAILOVER=YES)(ADDRESS_LIST=(ADDRESS=(PROTOCOL=tcp)(HOST=[server])(PORT=1523))(ADDRESS=(PROTOCOL=tcp)(HOST=[server])(PORT=1523)))(CONNECT_DATA=(SERVICE_NAME=ebusd)))
Related articles
  • Error While Deploying the BPEL Process using obant script 10-11

    Hi All, I am getting the following error while deploying the BPEL Process using obant script. we are using the BPEL Version 10.1.2.0.2.Any information in this regard will be really helpful. Buildfile: build.xml main: [bpelc] file:/home5102/dibyap/sar

  • Error while deploying the BPEL process 10-11

    Hi All, I'm getting the following error while deploying the BPEL process. "Error: [Error ORABPEL-10903]: failed to read wsdl [Description]: in "bpel.xml", Error loading schemas from wsdl. Error while loading schemas from wsdl file at locati

  • Getting Error While deploying the BPEL process 10-11

    Hi All, I am getting the following error while deploying the BPELProcess. The BPEL process is simple one which is having a Recieve from client and another Recieve from FTPAdapterfor Recieve Operation. Help me in resolving this. Thankyou. Process "BPE

  • Urgent:Error while deploying the BPEL process 10-11

    Hi, I am doing a BPEL process to insert some data into employees table depending upon the employee Number. Means before inserting data, a check should be made whether that employee number already exists or not.If it exists then we have to update the

  • RequestTimeoutException error while invoking a BPEL process using RMI 10-11

    Hi, I am getting RequestTimeoutException error while invoking a BPEL process using this code: Locator locator = LocatorFactory.createLocator(jndiProps); String compositeDN = "default/"+processName+"!1.0"; Composite composite = locator.

  • Error while deploying a BPEL process 10-11

    Hi All, When I try to deploy a BPEL process, I am getting the following error: BUILD FAILED C:\jdevstudio10133\jdev\mywork\batch_app\batch_proj\build.xml:79: A problem occured while connecting to server "localhost" using port "8888": O

  • Error while deploying same BPEL process created by jd10.1.3.4 then 10.1.3.3 10-11

    Hi, My SOA suite is in 10.1.3.3. I have created a BPEL process using jdeveloper 10.1.3.4 and deployed it in SOA suite 10.1.3.3, but when I created a same (everything same, even name) with jdeveloper 10.1.3.3 and deployed it, it is giving me the below

  • Compilation error while deploying my BPEL process : ORABPEL-05215 10-11

    Hi, I have created a BPEL process and when I try to deploy it, am getting the following error : BUILD FAILED D:\SoftWs\JDeveloper\jdev\mywork\AIASamples\CreateCustomerPartyPortalProvABCSImpl\build.xml:79: A problem occured while connecting to server

  • Error while deployoing the bPEL Process 10-11

    Hi , I'm getting the below error when i'm trying to deploy a BPEL Process. It got deployed and in the OPMN log i see the below error: May 20, 2008 12:34:21 PM org.apache.commons.httpclient.HttpMethodDirector executeWithRetry INFO: Recoverable excepti

  • While deploying the BPEL Process I am getting Error. 10-11

    I have BPEL Process "bpel_GetReSARMSJournalsToOracle_1.0.jar" and I am deploying this process via BPEL Console. While deploying this process I am getting the below error. SelectReSARMSJournalsService.wsdl]: Error while setting JCA WSDL Property.

  • AuthorizationFailure Error while executing the BPEL Process 11-30

    Hi, We have created BPEL Process with Partner Link, while executing BPEL Process we are facing the following error as <Summary>AuthorisationFailure: User Not Authorised to execute Service. </Summary> We are currently using SOA 10.1.3.0.. Pleas

  • Error in compiling the BPEL process 10-11

    Hi, I am getting the following error while compiling the BPEL process. Its a simple process with a Pick activity and have two onMessage activities. One of the activity is having the correlation set and another one is not. Is that the problem ? If yes

  • Error while deploying to BPEL 11.1.1.3 10-11

    Hi I encountering a problem while deploying my bpel process. I am able to deploy the same process in the environment with Enterprise manager version 11.1.1.4 whereas when i try to deploy the same jar file in another environment with enterprise manage

  • Error while deploying a business process 10-11

    Hi all. Am new to Integration Server development. I got this error while deploying my business process. ERROR: <Feb 15, 2004 3:19:41 PM GMT+05:30> <Warning> <DRS> <BEA-002506> <The current ve rsion 6 for DataIdentifier DataIdent

  • Error while executing the compilation process 10-11

    Hi, ISA Framework: com.sap.engine.services.servlets_jsp.server.jsp.exceptions.CompilingException: Error while executing the compilation process:  javac: invalid flag: "/usr/sap/CJP/J06/j2ee/cluster/server2/apps/sap.com/crm~isauseradm/servlet_jsp/isau

  • Error while deploying the project to ESB and deleting the services in ESB 10-11

    Hi, I am tiring to deploy a project to ESB, but I am getting this exception. error code: 0 : 10 summary: An unhandled exception has been thrown in the ESB system. The exception reported is: "javax.transaction.RollbackException: Timed out at com.everm

  • Error while deploying the SC on server..... 10-11

    Hi, We are trying to deploy a Software Component that we created and when we try to deploy it on our server, it gives us the following the error : Application error occurred during request processing.   Details:   Error [com.sap.engine.services.servl

  • Deploying SOAOrderBooking BPEL Process using ANT 10-11

    I cannot resolve the following error when deploying this process - all services are reqistered and deployed as specificed in the demo The error says 'cannot get deployment manager' and some messages about a URI de descriptor | Deploying workflow form

  • Getting an error while deploying the Quiz application in NWDEV 10-11

    Hi, I am getting an error while deploying the Quiz application in NWDEV. Please check this error log. It looks that it is not getting the Question.properties file but the file is already specified in the desired location. Error log: Detailed Error In

  • Error while creating the DWH tables using DAC 10-11

    Hi, I am getting error while creating the DWH tables using DAC. I have created a ODBC DSN using merant driver with DAC repository DB credentials and the test connection is successful. And while creating the tables i gave the olap dw credentials and t